カテゴリ 重要度 ステータス 解決状況 登録日時 最終更新
ゲームプレイ重要 (ゲーム)解決済み修正済み2018-05-24 23:462018-05-28 06:53
 
テスターMrGW担当者AJRソースcoco12.cpp
バージョン0.197発生バージョン修正バージョン0.198
フラグ
セット Other Coco related drivers
セット詳細
coco - Color Computer
 
概 要オーディオDACの問題。
詳 細William Schaub reported this issue to me after discovering the issue doing some software development. William's comments:

"There are two programs on the 1bit.dsk
SLTON.BIN assembled from slton.asm with lwasm with a listing in slton.lst
This program appears on page 278 of the Assembly Language Programming for the Color Computer (1985) (Laurence A Tepolt).pdf file.
Block at $4000 (16384) of length $003A ( 58): end at $403A
BIN file length: $0044 ( 68)
Entry point : $4000 (16384)
Content length : $003A ( 58)
Overhead : 17.2 %
Single continuous block goes from $4000 (16384) to $403A (16442)



P25.BIN: assembled from P25.ASM with lwasm with a listing in P25.lst this program appears as program 25 in the 6809_ch14_15.pdf file.
Block at $3E00 (15872) of length $0124 ( 292): end at $3F24
BIN file length: $012E ( 302)
Entry point : $3E00 (15872)
Content length : $0124 ( 292)
Overhead : 3.4 %
Single continuous block goes from $3E00 (15872) to $3F24 (16164)

On MAME these two programs are totally silent. On XRoar and a real Coco 2 they both produce sound.
I think somehow the 1bit dac is not being routed properly somehow."
再現手順Mount 1bitsound.dsk

LOADM "SLTON.BIN"
EXEC

... or ...or

LOADM"P25.BIN"
EXEC

You will not hear any audio. You will on a real Coco.
追加情報Thanks for any help you can provide!
 
添付ファイルzip file1bit-bug.zip (2018-05-25 00:06)